Jump to content

Temp Fix for Glitchy Runescape


Recommended Posts

Harro. RS is glitchy as hell with loading at the moment, and i found a temp fix.


First try deleting your Jagex cache, usually found in C:\.jagex_cache_32. Then try loading using this link (legit link, don't accuse me of phishing):




No idea why it works, but i was unable to load RS for a good 20 minutes, tried that link and it worked first time. I randomly found the link in the game.ws source and was wondering what it did, tried it and it worked.



Legalize baby punching. Tax and regulate it. Punch babies erry day.

Link to comment
Share on other sites

There is already a thread about this (not sure where it went), you don't need to load that link to my knowledge, just clear your cache (also in your browser) and it should work again if you had troubles. Jagex is trying to find a permanent fix for this problem (see the RSOF technical forum for more info).


edit: here it is: http://forum.tip.it/topic/300642-anyone-got-logging-in-issues/ see the quote in the post of kimberly for more details.


Retired item crew

I would like to be credited as essiw at the website update & corrections forum. Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.