Jump to content
Sign in to follow this  
NYCBOII123

Runescape wont respond on mac 10.8.1

Recommended Posts

I havea Macbook Pro that runs Runescape perfectly. I recently bought a new iMac. They are both running 10.8.1. The problem is that when the Runescape Applet opens, it loads and everything but when I have to type in my login info, it wont respond. Meaning it won't let me type anything I click the line to type but nothing happens. Any ideas how to get around that?

Share this post


Link to post
Share on other sites

Moved to Tech and Computers.


rc1tzc.png

☢ CAUTION ☢ CAUTION ☢ CAUTION ☢ CAUTION ☢

Share this post


Link to post
Share on other sites

i have the same problem, havent found a solution yet, though

Share this post


Link to post
Share on other sites

There are issues playing Runescape with Java 7 on Macs (only effects Lion or higher) so your new iMac (depending how new it is) may already have Java 7 installed on it, in which case you should be able to downgrade to an earlier version.

 

Software mode also does not work on Mountain Lion so that is another possible cause, so you could try booting RS in safe mode (hold cmd + s while the game is loading) and switching to Open GL if you get in.

 

Hope this helps anyway.

  • Like 1

SLwQsg1.png


"Unfortunately, the real world isn't the same as a fairy tale."


Share this post


Link to post
Share on other sites

There are issues playing Runescape with Java 7 on Macs (only effects Lion or higher) so your new iMac (depending how new it is) may already have Java 7 installed on it, in which case you should be able to downgrade to an earlier version.

 

Software mode also does not work on Mountain Lion so that is another possible cause, so you could try booting RS in safe mode (hold cmd + s while the game is loading) and switching to Open GL if you get in.

 

Hope this helps anyway.

so you are saying i should downgrade my java version? because both my macs are running 10.8.1 but runescape only works on my macbook pro

Share this post


Link to post
Share on other sites

10.8.1 isn't the Java version.

Share this post


Link to post
Share on other sites

This is a Mountain Lion bug. The applet does not re-render any frames after the login screen if you are playing in Software mode. You can load it in safe mode, or even easier, resize the applet to force it to redraw. Click the settings up the top right then resize the applet so it renders again and you can see where to click next. Then select OpenGL mode and that should fix it.


Dtwizy.png

santasigcj7.gif

Share this post


Link to post
Share on other sites

Open up runescape in safari, then open up the downloadable client with runescape in safari still running and it should work properly. After that, you can close safari. Keep it on safe mode or else it will just freeze up. It's very annoying to do this, but i've found this is the only way to get runescape to work (for me anyway).


1xa.png.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.