Jump to content
Sign in to follow this  
Hooded Billy

Blood Runs Deep issues

Recommended Posts

So, I did Blood Runs Deep yesterday, and there were issues with the dagannoths. First:


"21. Continue walking south through the passage and kill the two Dagannoth Sentinels (level 193) guarding the Lair's entrance. Extreme caution is advised, as the two sentinels are high-level, can use all three combat styles, and will heal one another occasionally. Use Balmung to attack them alternately (switch after every two attacks or so). If you only focus on one sentinel, the other will heal it too quickly for the sentinel to be killed..."


I really tried to do that, but it wasn't working, so I thought " I'll try to attack only one first, it's not working anyways..."

And then I killed him :mellow: Then I'd turn to the other one and killed him too. And both didn't heal each others.


"24 (...) To defeat her, as with the previous Dagannoth Mother in Horror from the Deep, you must attack her with a certain form of attack based on the colour of her hide. Make sure you have all the attack styles listed below, as she might stick to just two colours when she doesn't take damage. Otherwise, she'll alternate between seven different colours, so you must pay close attention to ensure that you continue to deal damage. Below are the various colours she'll turn (they appear in your chat window) and the corresponding attacks you should use..."


She didn't change colours :mellow: She was grey for the entire fight. Then I just fought her with melee... I didn't even eat.


You might think I'm lying or I'm lucky for that, but it was...boring :mellow:

I was all prepared for that, excited and such...



Did it happen with someone too?



Share this post

Link to post
Share on other sites

Last time I did Blood Runs Deep (within the last few months) I had the same problem; I was attacking the sentinels one at a time and it wasn't working when I alternated. So I tried to just kill one; and it worked. I can attest to that part being true.


As for the queen; I do believe you've encountered a glitch, possibly. I don't think I had the luxury of only using melee.


Hope this helps :)

  • Like 1

All_My_Love.png Bun_Dem.png


max.png 50.png

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.