Jump to content
Sign in to follow this  

Stuck on "Loaded Update List"

Recommended Posts

I haven't had any problems until today, I tried to log onto OSRS and both the official 2007scape client and OSBuddy keep getting stuck at "Loaded Update List"

I have completely deleted and reinstalled both clients and updated Java. My computer is relatively brand new (3 months).  


Computer Specs-

Intel Core i5-6600k CPU @ 3.50 GHz

32.0 GB of RAM

MSI GTX 1060 Video Card

Windows 10 64bit

Share this post

Link to post
Share on other sites

Pardon my being near a month late, but did you kill the "jagexcache" folder, and kill a file named "jagex_cl_runescape_LIVE.dat", both at "C:\Users\<your username>"???  If not, then you didn't completely clear things when trying to reload RuneScape fresh to your computer.  In case you don't believe me, just wait for somebody to confirm what I'm saying here, which hopefully shouldn't take too long. :huh:


~D. V. "Just trying to provide a useful tidbit to fix your issues..." Devnull

tifuserbar-dsavi_x4.jpg and normally with a cool mind.

(Warning: This user can be VERY confusing to some people... And talks in 3rd person for the timebeing due to how insane they are... Sometimes even to themself.)

Share this post

Link to post
Share on other sites

If anyone out there is in this situation again - like I was tonight - here's what happened to me:

Had this same issue and couldn't for the life of me find an answer anywhere but somehow I fixed it (I have absolutely no idea how or why, but this is exactly what I did)

  1. Read through a thousand forums without finding a confirmed solution, just an indication that the java update was the issue and an indication that it could be due to some sort of sound settings
  2. Deleted all cache and literally anything that was associated with the word 'jagex'.
  3. Still not working so I downloaded the official OSRS client, still the same issue.
  4. Chucked a little tantrum because everything was systematically messing up on my computer. (this step is important)
  5. Looking through forums to post my issue and seek help and computer froze
  6. Restarted computer and RS client started up and loaded all the way
  7. Thought i'd see if OSbuddy would do the same and it did. - Hooray
  8. Pat myself on the back because even though I have no idea what I did - I'm a genius.

    You're welcome.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.