Jump to content
Due to the significant updates that have taken place, you now need to login with your display name or e-mail address, NOT your login name. ×
Due to posts that are 5+ years old being rebuilt, some of the older BBCodes may not have converted properly but still be in the post. Most posts are unaffected but some using what was our custom BBCode (like [spoiler]) will be a bit broken. ×
Sign in to follow this  
JonReled

Swiftkit won't load Runescape

Recommended Posts

I really need help. I heard about Swiftkit yesterday, and I installed it, but i can't seem to get it to work. I click on the "Play RS" thing in the client, it leads to RS3 main page, i click "Play Now" and it goes to a screen saying "Launching Runescape" with a rotating loading thing in the bottom. After a while, both of those disappear and something saying "Thanks for playing" appears but the game doesn't start up anywhere. Please help me.

Share this post


Link to post
Share on other sites

Whats happening is that the runescape website is trying to load the "official client" this is fine however at the moment swiftkit isn't looking for it so it's not doing anything.

 

On the side  of swiftkit if you click the drop down arrow on there a box to check use "RS client".

 

if you check that Swiftkit will start to look for the official client and load the game.

 

ZAcTlvy.png


simmo200.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.