Jump to content
Due to the significant updates that have taken place, you now need to login with your display name or e-mail address, NOT your login name. ×
Due to posts that are 5+ years old being rebuilt, some of the older BBCodes may not have converted properly but still be in the post. Most posts are unaffected but some using what was our custom BBCode (like [spoiler]) will be a bit broken. ×

ricardocravo

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About ricardocravo

  • Rank
    Chicken Feather

Profile Information

  • Gender
    Not Telling
  1. thank you, but i still haven't recieved any reply except yours, and runescape still not working, this means swiftkit doesn't support EOC anymore just OSRS right? guess so :s
  2. hello i just installed swiftkit cause i used it 6 years ago, right now it cann't oppened runescape 3 or eoc, it says it's not compatible and it forces me opening the runescape client, what's going on ?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.