Jump to content

Mousekeys double jumps


i_r_slayer

Recommended Posts

I have used mousekeys many times without trouble until now. It was working perfectly fine before I took a 3 month or so break from runescape and now when I use it, any direction I move, the mouse acts as if I press the key twice. I have not made any changes to my mouse or keyboard settings to my knowledge, and I have fiddled with things such as repeat delay in the keyboard settings and enhance pointer precision in the mouse settings without any success. Pressing the 5 key over an icon on my desktop does not open the folder like the plus (double click) key does, so this problem seems to be limited to the directional arrows.

 

Edit: Something I've noticed about the behavior that doesn't seem quite right is that when moving the mouse around, it seems to act without repeat delay. If I remember correctly, holding a directional button down should take a second before it starts to constantly jump. In my case, the second I hold a key down, it instantly starts spamming the jumps. If I'm very careful about it, I can get the mouse to jump only one space, but the common key press is usually 2 jumps.

yuki2d.png

Link to comment
Share on other sites

Acts as if you've pressed it twice like moves twice as far? Because you could just reduce your mousekey speed.

 

No, it quickly makes two jumps. Halving the distance doesn't work because pressing 5 too quickly will cause me to click somewhere in the middle of the jumps.

 

Something I've noticed about the behavior that doesn't seem quite right is that when moving the mouse around, it seems to act without repeat delay. If I remember correctly, holding a directional button down should take a second before it starts to constantly jump. In my case, the second I hold a key down, it instantly starts spamming the jumps. If I'm very careful about it, I can get the mouse to jump only one space, but the common key press is usually 2 jumps.

yuki2d.png

Link to comment
Share on other sites

  • 1 year later...

Sorry for bumping an old topic, but I came here from a google search after having the same problem and managed to fix it. The problem started for me when i accidentally turned on something called "filterkeys" and then switched it off again, and suddenly my mouskeys had no delay after the 1st jump. The solution is to go into the filterkeys settings, click on the linkl to repeat and slowkeys settings, and even when filterkeys are disabled, changing the options like this: 1bd59e5d46de1563ae6b6ca98b9049cc.png somehow fixes the problem, even though this should be a completely unrelated option and has a completely different function when filterkeys is enabled. I'm unsure how these settings are on a computer that this has never happened to, but I am guessing this is what they will be like. Changing that first 0.3 seconds value actually allows you to change the delay if you want to.

dukky.png

dukky.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.