Jump to content

Help with a Mac iBook G4


Lord Diddy
 Share

Recommended Posts

I have a lot of experience with Windows, but OSX I've recently been learning about.

 

Well my brother brought his old ibook G4 running Panther (10.3) to me hoping for an upgrade to a newer OSX. Im sure this can only handle Leopard, maybe SL. I'll post up complete specs later.

 

I have the CD for Leopard (10.5) but sadly the CD/Dvd rom is not working properly. I managed to get the .dmg image file from the CD using another Macbook Pro, but the bootable USB drive isnt recognized as a bootable disk. The USB is recognized in OSX (where I made the usb bootable) but when I bring up the boot options it only shows the HDD with Panther installed.

 

Is there any alternatives to installing an OS without CD, and without usb boot capability? I'm not sure if the limitation is from the currently installed Panther or the model itself.

 

Specs

Hardware Overview:

 

Machine Model: iBook G4

CPU Type: PowerPC G4 (1.1)

Number Of CPUs: 1

CPU Speed: 1.2 GHz

L2 Cache (per CPU): 512 KB

Memory: 768 MB

Bus Speed: 133 MHz

Boot ROM Version: 4.8.7f1

 

System Software Overview:

 

System Version: Mac OS X 10.3.9 (7W98)

Kernel Version: Darwin 7.9.0

Boot Volume: Macintosh HD

Computer Name: justin says’ Computer

User Name: Isaiah (justinsays)

 

Memory:

 

DIMM0/BUILT-IN:

 

Size: 256 MB

Type: Built-in

Speed: Built-in

 

DIMM1/J7:

 

Size: 512 MB

Type: DDR SDRAM

Speed: PC2700U-25330

 

PCI/AGP Cards:

 

ATY,RV280M9+:

 

Type: display

Bus: AGP

VRAM (Total): 32 MB

Vendor: ATI (0x1002)

Device ID: 0x5c63

Revision ID: 0x0001

ROM Revision: 113-xxxxx-142

 

Display:

 

Type: display

Display Type: LCD

VRAM (In Use): 32 MB

Resolution: 1024 x 768

Depth: 32-bit Color

Main Display: Yes

Mirror: Off

Online: Yes

 

ATA:

 

ATA-3 Bus:

 

MATSHITA CD-RW CW-8123:

 

Manufacturer: MATSHITA

Model: MATSHITA CD-RW CW-8123

Revision: CA10

Serial Number:

Drive Type: CD-RW/DVD-ROM

Disc Burning: Apple Supported/Shipped

Removable Media: Yes

Detachable Drive: No

Protocol: ATAPI

Unit Number: 0

Socket Type: Internal

 

ATA-6 Bus:

 

Vendor ID: 0x106b

Device ID: 0x003b

Revision ID: 0x0000

 

FUJITSU MHT2030AT:

 

Capacity: 27.94 GB

Model: FUJITSU MHT2030AT

Revision: 819C

Serial Number: NN96T4B134R9

Removable Media: No

Detachable Drive: No

BSD Name: disk0

Protocol: ATA

Unit Number: 0

Socket Type: Internal

OS9 Drivers: No

 

Macintosh HD:

 

Capacity: 27.82 GB

Available: 3.66 GB

Writable: Yes

File System: Journaled HFS+

BSD Name: disk0s3

Mount Point: /

randomkcopyq.png
Link to comment
Share on other sites

Well, Here is what google says (Dont use Macs so I can't really say anything from personal experience): Instructions for setting up usb drive to install Mac OS X Leopard

 

Also, Leopard is the highest version of OS X that is supported by that model.

Luna_pirate_signature.png

Thanks to DrCue at DeviantArt for the signature source

Link to comment
Share on other sites

Yeah I've been using a very comprehensive guide similar to the one posted. I've made the USB Bootable and have tried on a Macbook Pro (OSX 10.6) and is recognized. Sadly I feel that my model or OSX version simply cannot boot from USB.

 

Also to make clear, I've been making the USB OSX drives using the ibook with 10.3 (Panther). Would somehow I find it more successful to make one using the MacBook Pro because of its wider range of options?

 

Any help is appreciated.

randomkcopyq.png
Link to comment
Share on other sites

Well, your main issue is that Power PC based Macs don't actually support booting from USB, though you can force it to do so through some advanced option or something like that (Again, I am just using google, so I cannot say anything on what it actually does) : boot iBook G4 from USB

Luna_pirate_signature.png

Thanks to DrCue at DeviantArt for the signature source

Link to comment
Share on other sites

I've tried that already, A main question I'd like to know is whether the limitation of booting from USB is from the model itself, or the OSX version that it is currently running. So that hypothetically if I did install Leopard on it, would it finally be USB bootable?

 

Hmm there must be something that I'm missing...

randomkcopyq.png
Link to comment
Share on other sites

The ComboDrive in your iBook is unable to read the dual layer disk that Leopard is written on. If this is the only reason why you think the drive is dead, you may be in luck. I am fairly confident that PowerPC Macs are not able to boot from USB. It is intrinsic to their firmware and does not matter what OS you're on. It is possible to modify the firmware to alter this.

 

If you want to boot from external drive, you'll probably want to boot from FireWire.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.