Jump to content
Due to the significant updates that have taken place, you now need to login with your display name or e-mail address, NOT your login name. ×
Due to posts that are 5+ years old being rebuilt, some of the older BBCodes may not have converted properly but still be in the post. Most posts are unaffected but some using what was our custom BBCode (like [spoiler]) will be a bit broken. ×
Sign in to follow this  
winstonlievsay

RS Won't Load

Recommended Posts

I've been trying to get the game to load now for a while, I just came back to runescape after a fairly long break. The game always gets stuck on this screen:

 

http://desmond.image...png&res=landing

 

It gets stuck on the part where It says runescape and underneath it has a circle with spinning dots... the dots spin for a few seconds then it freezes and nothing happens.

 

I've tried using many different browsers and I've uninstalled and re installed Java and nothing has helped thus far. Any thoughts or input would be appreciated.

Edited by Lord Paul
Added direct link to image

Share this post


Link to post
Share on other sites

I've fixed your image so that it links directly to it.

 

Have you tried the Runescape Game client?


Working on max and completionist capes.

2435/2475

Share this post


Link to post
Share on other sites

I get the same problem loading on Swiftkit. And on internet explorer or chrome, it just shows a black screen. I even tried re-downloading all my java and adobe stuff. Nothing works.

Share this post


Link to post
Share on other sites

Try removing all your Jagex files from your User folder. It worked for a guy I live with.

Share this post


Link to post
Share on other sites

I've had this problem recently as well, i just keep reloading the page until it goes through.... Takes FOREVER. I tried deleting my temp files and it seemed to help a bit, hopefully that's a fix.


Mlskid.png
Summoning help:
[hide=Wio, lol]logioh.png[/hide]

Share this post


Link to post
Share on other sites

Be sure to clear your browsers cache and perform a few hard refreshes by pressing the F5 key. Let the page load fully each time before refreshing again, however. Then give it a shot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.