Jump to content
Sign in to follow this  
Logdotzip

DirectX Issues

Recommended Posts

well I had gone through windows built in driver udpater, which ma have been the problem. But theyre up to date now. deleting the cache did nothing for me.

 

it is a fairly new graphics card, they may not have tested rs on it yet.

 

but as of now the problem is still unresolved

Share this post


Link to post
Share on other sites

well I had gone through windows built in driver udpater, which ma have been the problem. But theyre up to date now. deleting the cache did nothing for me.

 

it is a fairly new graphics card, they may not have tested rs on it yet.

 

but as of now the problem is still unresolved

 

What card is it? Afaik all the 6xxx and 5xx cards play RS just fine.

Share this post


Link to post
Share on other sites

I'd assume you're running nvidia optimus by default? Which graphics card drivers did you update? Try updating the other one because it may be that optimus isn't detecting RS as a resource hog and is using the intel graphics card instead.


2d26mw.gif

Why can't the Big Bang be done by the hand of God?

It could have, but it is next to impossible because it also could have been caused by the flying spaghetti monster, or one of the other infinite number of deity possibilities.

Share this post


Link to post
Share on other sites

Honestly haven't a clue when it comes to stuff like this, but maybe this will be of some service, as I don't see any way to turn off Optimus

 

99af1ced829ff83185605a5e088f95d4.png51129c97f96543553f9319933fe062b2.png

 

Share this post


Link to post
Share on other sites

 

You'll save a lot by getting that same desktop on Newegg if it is listed on Newegg or other websites that sell computers. Best Buy is generally overpriced.

Share this post


Link to post
Share on other sites

You'll save a lot by getting that same desktop on Newegg if it is listed on Newegg or other websites that sell computers. Best Buy is generally overpriced.

I personally second this. No need to get gouged! :?

 

~D. V. "Dodge the overpay!" Devnull


tifuserbar-dsavi_x4.jpg and normally with a cool mind.

(Warning: This user can be VERY confusing to some people... And talks in 3rd person for the timebeing due to how insane they are... Sometimes even to themself.)

Share this post


Link to post
Share on other sites

Did the checks myself, I save about $20, but I have to wait for shipping. I'll pay the twenty because a BB is 15min from me. Ordering my Monitor and webcam off Newegg, using an old monitor until then. Anyways, thanks for the help everyone, kind of glad I didn't find a fix, that $1235 laptop was not worth it.

Share this post


Link to post
Share on other sites

Shame this was never solved. I have the exact same problem with my brand new laptop. :S

 

It has an effect on me recording gameplay though.

Software Mode isn't detected by fraps, so it doesn't focus itself on Runescape.

OpenGL works fine, but when I try to record Runescape, it drops to a stable 5 FPS as long as it is recording. 30 FPS when not recording. OpenGL also crashes after I go through a few "Loading - Please Wait"s.

DirectX works perfect, smooth 30 FPS both when Recording and when not recording. However the issue you were experiencing happens when I turn on any for for AA on RS.

Share this post


Link to post
Share on other sites

Shame this was never solved. I have the exact same problem with my brand new laptop. :S

 

It has an effect on me recording gameplay though.

Software Mode isn't detected by fraps, so it doesn't focus itself on Runescape.

OpenGL works fine, but when I try to record Runescape, it drops to a stable 5 FPS as long as it is recording. 30 FPS when not recording. OpenGL also crashes after I go through a few "Loading - Please Wait"s.

DirectX works perfect, smooth 30 FPS both when Recording and when not recording. However the issue you were experiencing happens when I turn on any for for AA on RS.

I am having the same trouble as you, just made a thread about it. I think it has to do with NVIDIA Optimus as another poster suggested. So the question is how to fix it and make the NVIDIA graphic card run instead of the intel one for runescape.

 

EDIT: Managed to fix it by using NVIDIA control panel.

Share this post


Link to post
Share on other sites

I am having the same trouble as you, just made a thread about it. I think it has to do with NVIDIA Optimus as another poster suggested. So the question is how to fix it and make the NVIDIA graphic card run instead of the intel one for runescape.

 

EDIT: Managed to fix it by using NVIDIA control panel.

 

I fixed it for myself putting a shortcut to Firefox on the desktop and when I want to run RS I right click and select "run with Nvidia..." instead of Intel graphics.


2d26mw.gif

Why can't the Big Bang be done by the hand of God?

It could have, but it is next to impossible because it also could have been caused by the flying spaghetti monster, or one of the other infinite number of deity possibilities.

Share this post


Link to post
Share on other sites

Any idea why OpenGL crashes after going through several "Loading - please wait"s?

 

Also having the same issue with DirectX, only reason I'm using it is because Software graphics look awful and OpenGL is unstable.

aadir.png

 

If this DirectX issue can't be fixed, does anyone know how to deal with OpenGL's crashing?


6Ij0n.jpg

In real life MMO you don't get 99 smithing by making endless bronze daggers.

Share this post


Link to post
Share on other sites

Rook and Askthedude managed to fix it for me.

 

By right clicking the Runescape Client, then selecting Run with High Performance NVIDIA, DirectX with AA 4x looks just like it should. I'll assume the glitch has something to do with the Intel Graphics since everyone with this issue seems to have Intel Graphics as well as another one (me included).

 

The OpenGL crash is still a mystery to me, but I run a stable 30 FPS with DirectX, so I'll probably be using that anyway from now on while on my laptop.

 

Thanks for the help guys! :)

 

Edit: Just read a message from Rook about fixing it through the NVIDIA Control panel if you have a dual graphics card.

 

I hope you have the same dual graphic card problem that I did, NVIDIA Optimus is not working properly for you. Go to NVIDIA Control panel, In the 3d settings tree, select Manage 3D settings, if you want select NVIDIA as your "preferred graphics processor", or instead just go to the "Program settings" tab and add Java and firefox to run using NVIDIA graphics.

 

Feels good to play with Anti-aliasing again. :P

Share this post


Link to post
Share on other sites

I hope you have the same dual graphic card problem that I did, NVIDIA Optimus is not working properly for you. Go to NVIDIA Control panel, In the 3d settings tree, select Manage 3D settings, if you want select NVIDIA as your "preferred graphics processor", or instead just go to the "Program settings" tab and add Java and firefox to run using NVIDIA graphics.

 

Appears that I'm running an integrated card because I can't select a preferred processor :(

33748820.png

32745974.png

Any idea of another way to work around this?

 

System Info:

50857878.png

Thanks guys.


6Ij0n.jpg

In real life MMO you don't get 99 smithing by making endless bronze daggers.

Share this post


Link to post
Share on other sites

http://forums.lenovo.com/t5/IdeaPad-Y-U-B-V-and-Z-series/FIXED-Y570-Nvidia-Optimus-not-working/td-p/441895

 

I hope you have the Lenova Y570 as this was the only thing I could find. I am sorry but I am just an amateur who solves all of my PC problems by googling haha. Wish I could help more, tell me if this works otherwise we will do some more digging. Also try to make sure all your drivers are to date, that usually solves most problems.

Share this post


Link to post
Share on other sites

Apparently I'm banned from using that site O_o How odd.

And well, I'm running the Y470, but it's probably close enough.


6Ij0n.jpg

In real life MMO you don't get 99 smithing by making endless bronze daggers.

Share this post


Link to post
Share on other sites
***FIXED: I didn't know until digging thoroughly through the internets that the Y570 has a manual switch to turn on the nvidia gpu. It's in the lower right hand corner and you slide it over and hold it until the light comes on... I'm much relieved.

 

Try this then. Search for that switch :P

Share this post


Link to post
Share on other sites

I laughed at the simplicity of it. Then realised how low-tech I am :P

Thanks a lot for finding that for me, yipee ! Back to 4x AA :)


6Ij0n.jpg

In real life MMO you don't get 99 smithing by making endless bronze daggers.

Share this post


Link to post
Share on other sites

I laughed at the simplicity of it. Then realised how low-tech I am :P

Thanks a lot for finding that for me, yipee ! Back to 4x AA :)

No problems, have fun. :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.